
Dialer Help Index
The Windows Telephony Dialer allows you to place calls using your modem or another Windows 
Telephony device. You can enter numbers into Dialer directly. Dialer can also place calls on behalf of 
other applications when those applications, using the appropriate Assisted Telephony functions, pass the 
number to be dialed.

To learn how to use Help, press F1.
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Dialing a Call

To dial a call
1 Select the Number to Dial field by clicking in it, typing Alt-N, or tabbing to it.

2 If a number is already displayed in the field and is already selected, but it is not the number you want
to call, or if no number is displayed, type the number you want to dial. The number may be in either 
dialable form or international form.

3 You can edit the phone number before dialing, if you wish.

4 When the number is correctly entered, press Enter, Alt-D, or click the Dial button to dial it.

If you frequently dial the same number, you may want to store it on a speed-dial button.

See Also
Redialing the Last Call; Redialing a Previous Call; Redialing a Call from the Call Log; Redialing a Call 
from another Application; Stopping a Call that is Being Dialed; Setting Dialing Options; Defining Dialing 
Locations; Defining Telephone Calling Cards



Editing the Telephone Number before Dialing

You can use standard Windows procedures to edit numbers you have entered before dialing. For 
example:

1 All standard keyboard and mouse techniques are available, including using arrow keys and mouse 
keys for positioning the cursor, using the shift key to extend the selection, using the Home and End 
keys to move the cursor to the beginning or end of the number, and typing to replace selected text.

2 The commands on the Edit menu can be used to cut or copy digits to the clipboard, paste from the 
clipboard, and delete digits.

3 You can also use the shortcut keys indicated on the Edit menu.

4 After a call is placed, the dialed number remains in the Number to Dial field so that you can edit it 
for redialing if there was a problem (or even if the called line was busy). The entire number is 
automatically selected. This means that typing a new number replaces the previous number (you do 
not need to use the Delete or Backspace keys to remove it first).

See Also
Editing Speed-dial Button Settings



Redialing the Last Call

To redial a call you just attempted
1 After you hang up to disconnect a call (if it is busy, there is no answer, or so on), Dialer retains the 

number just dialed in the Number to Dial field.

2 Press Enter, Alt-D, or click the Dial button to try the call again.

See Also
Dialing a Call; How to edit the telephone number before dialing; Redialing a Previous Call; Redialing a 
Call from the Call Log



Redialing a Previous Call

Dialer keeps track of the last 20 distinct numbers that you dialed (if you dial the same number more than 
once, it appears in this list only once). 

To redial a previous call
1 Click the drop-down button that appears to the right of the Number to Dial field. The list of 

previously dialed numbers will be displayed below the Number to Dial field.

2 Select the number to be redialed from the list. If there are more numbers than can be displayed at 
once, you can scroll through the list. The number you click will be displayed in the Number to Dial 
field.

3 You can edit the number before dialing if you desire.

4 Press Enter, or Alt-D, or click the Dial button to dial the number.

Note that the most recently dialed numbers appear at the top of the redial list and the last number dialed 
is moved to the very top of the list.

See Also
Dialing a Call; How to edit the telephone number before dialing; Redialing the Last Call; Redialing a Call 
from the Call Log; Storing Frequently Dialed Numbers in Speed-dial Buttons



Redialing a Call from the Call Log

To redial a call from the Call Log
1 If the Call Log window is not already visible, open it by selecting Show Log from the Options Menu.

2 Use the scroll bar, page up, page down, home, end, and arrow keys to select the entry in the log 
containing the number you want to redial.

3 Press Enter, or double-click the log entry to dial the call.

See Also
Dialing a Call; Redialing the Last Call; Redialing a Previous Call; Viewing the Call Log



Dialing a Call from another Application

Windows Telephony allows other applications to pass requests to call-manager applications such as 
Dialer for dialing calls. 

If the application you are using supports this feature, follow these steps
1 Select the spreadsheet cell, database form field, phone number, or other information to be dialed.

2 Invoke the dialing operation in the application, which may appear, for example, as a "phone" icon on 
the Toolbar, or as a "Dial..." command on a menu or button.

3 The application passes the phone number to Dialer through Windows Telephony functions. Dialer 
receives the number, and places the call as though you had typed the number yourself into the 
Number to Dial field and clicked the Dial button.

To add dialing capabilities to an application or macro you are writing yourself, first read the 
Assisted Telephony section of the Windows Telephony Application Programmer's Guide. To illustrate the 
simplicity of this interface, passing phone numbers to Dialer from a Visual Basic application can be done 
with two simple statements.

First, declare the function:

Declare Function tapiRequestMakeCall& Lib "TAPI.DLL" (ByVal DestAddress$, 
ByVal AppName$, ByVal CalledParty$, ByVal Comment$)

Then, to pass the request to Dialer, simply invoke the function using code such as:

retval& = tapiRequestMakeCall&(NumberToDial$, "", Name$, "")

You may also want to examine the returned value to determine whether the request was accepted (value 
0) or an error occurred (a negative value), and display an appropriate message to the user. See the 
Programmer's Guide for details on possible error return values.

See Also
Dialing a Call; Storing Telephone Numbers to Work from any Location



Stopping a Call that is Being Dialed

To stop a call that is being dialed
1 If a call is still in the process of being dialed, but dialing is not yet complete, click the Cancel button 

in the Dialing dialog. You can also press the Escape key, or press the Enter key if the Cancel button
is highlighted as the default button.

2 If dialing has completed but the call has not yet been connected, click the Hang Up button. Note that
some Telephony Service Providers (the low-level drivers that control telephone hardware) display 
their own dialogs that offer a "hang up" capability. The service provider for AT command-set devices 
included with Windows Telephony is an example of such a provider.

See Also
Using a Modem as a Dialer (special considerations)



Using a Modem as a Dialer

To use your modem as a dialer for voice calls
1 If you have not already done so, use the Telephony Control Panel to install and configure the 

Windows Telephony Service Provider for AT-command-set-based Devices that is included with 
Windows Telephony (ATSP.TSP), or another service provider that supplies similar features. Be sure 
to specify the correct serial port to which your modem is attached. The Online Help for ATSP.TSP 
(ATSP.HLP) gives detailed instructions about how to connect the wiring between your computer, your
modem, and your telephone so that the modem can be used as a dialer.

2 Many modems (such as those from Hayes Microcomputer Products, Inc.) include a "cut off" device 
which, when your modem is "off hook" (the "OH" light is on the front panel, indicating the modem is 
using the phone line), prevents you from interfering with the modem's phone call by disconnecting 
any equipment attached to the "phone" port on the modem.

If your modem has such a device, the Telephony Service Provider that controls the modem must 
place the modem on hook before you can talk on a call that you have dialed. However, the modem 
cannot detect and report that the called party has answered, and it also cannot detect that you have 
lifted the attached telephone and are ready to talk. That is why ATSP.TSP (and similar service 
providers) ask you to press a Talk button in a dialog after the complete dialing. It is important that 
you lift the telephone receiver before you click the Talk button; otherwise, your call is 
disconnected when you click Talk. These requirements are discussed in greater detail in the Online 
Help for ATSP.

See Also
Dialing a Call



Storing Frequently Dialed Numbers in Speed-dial Buttons

To store a number in a speed-dial button
1 If the number you want to store is already on your screen (in the Number to Dial field, in another 

application, or in the Call Log), select it, and use the Copy command on the Edit menu to place the 
number on the Clipboard.

2 Click an "empty" speed-dial button (one for which no text appears on the button). If there are no 
empty buttons, select a button for which you want to replace the settings, and click it using the right 
(secondary) mouse button. This will open the Program Speed Dial dialog.

3 In the Name field, type the text that is to appear on the button. Note that the field is the same width 
as the button, so if your text fits in the field without scrolling, it will also fit in the button. Also note that
if you used the Copy command in the Call Log window to copy an entry from the Call Log onto the 
clipboard, Dialer pastes only the Name portion of the entry into the Name field.

4 In the Number to Dial field, enter or paste the number you want to dial when you click the selected 
speed-dial button. Note that if you used the Copy command in the Call Log window to copy an entry 
from the Call Log onto the clipboard, Dialer pastes only the Number portion of the entry into the 
Number to Dial field.

5 Click Save to store the information on the button. Click Save and Dial to both save the information 
and dial it immediately. Click Cancel to discard the changes.

6 When you want to dial a call to the number stored on the speed-dial button, simply click the button.

See Also
Dialing a Call; Viewing the Call Log; Storing Telephone Numbers to Work from any Location



Editing Speed-dial Button Settings

To view and modify the contents of all speed-dial buttons at the same time
1 Select Speed Dial... from the Edit menu. The Edit Speed Dial dialog is displayed. It shows all the 

speed-dial buttons.

2 To display the contents of a particular speed-dial button, click the button. The button is highlighted to 
indicate that it is the button being viewed.

3 To change the button setting, edit the Name and Number to Dial fields at the bottom of the dialog. 
Note that changes to the Name field are reflected in the button caption displayed in the upper portion
of the dialog.

4 When you are finished changing the contents of one speed-dial button, you can click a different 
speed-dial button to view and edit its contents; this saves the changes you made to the button that 
was previously being viewed. Or, you can click the Save button at the bottom of the dialog to save all
your changes.

5 To discard all the changes you have made to all the speed-dial buttons, click the Cancel button.

See Also
Dialing a Call; Storing Frequently Dialed Numbers in Speed-dial Buttons; Storing Telephone Numbers to 
Work from any Location



Viewing the Call Log

To view the contents of the Call Log
Select Show Log from the Options Menu. The Call Log window is displayed. It may be necessary to 
move or resize the Call Log window to make the portions you want visible.

See Also
Redialing a Call from the Call Log; Hiding the Call Log; Selecting Types of Calls to Be Entered into the 
Call Log; Placing the Name of the Person Called in the Call Log; Purging Old Calls from the Call Log; 
Using Call Log Entries in other Applications



Hiding the Call Log

To close the Call Log window
Select Hide Log from the Options Menu in the main Dialer window. Or, double-click the System Menu box
in the upper-left corner of the Call Log window itself (or select Close from the System Menu of the Call 
Log window). Note that Call Log entries continue to be stored while the Call Log window is not visible; the 
updated log is displayed if you later select Show Log.

See Also
Viewing the Call Log; Selecting Types of Calls to Be Entered into the Call Log; Placing the Name of the 
Person Called in the Call Log; Purging Old Calls from the Call Log; Using Call Log Entries in other 
Applications



Selecting the Types of Calls Enter into the Call Log

To select the types of calls to be logged
1 Select Log... from the Options Menu in the Dialer window, or Options... from the Log menu in the 

Call Log window. Either choice displays the Call Log Options dialog.

2 To have Dialer log incoming calls, check the Incoming Calls box. Note that the Telephony Service 
Provider included with Windows Telephony (ATSP.TSP) does not handle incoming calls, so unless 
you've installed another service provider no information will actually be logged. Also note that the 
ability for Dialer to log information such as the name and number of the person calling is dependent 
on information provided by the service provider, which is likely to be further dependent on 
information provided by your telephony hardware. For example, you may have to subscribe to 
Caller*ID® in order to receive this information.

If you do not want incoming calls to be logged, click the Incoming Calls box to remove the check 
mark.

3 To have Dialer log outgoing calls placed through Windows Telephony, check the Outgoing Calls 
box. Dialer obtains the Name information for the Call Log from one of several sources, depending on
whether Dialer or another Windows Telephony application placed the call:

· If the call was placed by another application, Dialer includes in the log whatever name and 
number the other application provided to Windows Telephony as the call was placed.

· If the call was placed by Dialer, you are offered the opportunity to enter or edit the name to be 
stored in the log in the Active Call dialog displayed while the call is active, or the Disconnected Call 
dialog displayed after the call terminates. See Placing the Name of the Person Called in the Call Log
for more information.

4 Click OK to save the updated Call Log Options settings, or Cancel to discard your changes.

See Also
Redialing a Call from the Call Log; Viewing the Call Log; Hiding the Call Log; Placing the Name of the 
Person Called in the Call Log; Purging Old Calls from the Call Log; Using Call Log Entries in other 
Applications



Placing the Name of the Person Called in the Call Log

To place names into Call Log entries for outgoing calls
When you use Dialer to place a call (including calls requested by other applications, if those requests are 
processed by Dialer), Dialer displays the Active Call dialog after the call is connected, and the 
Disconnected Call dialog if the call is terminated by the remote party. The text that appears in the Name 
to Place in Call Log field in each of these dialogs is written into the Call Log when you press the Hang 
Up button, if you have requested (in the Call Log Options) that outgoing calls be logged.

Dialer presents a default entry in the Name to Place in Call Log field, if it has certain information 
available. This information can come from any of several sources:

· If the call was requested by another application, that application may have passed in a called party 
name as a parameter of the request; that name would be offered as the default.

· If you clicked a speed-dial button to initiate the call, the Name stored in and displayed on that button 
is offered as the default.

· If there is an entry in the Call Log for another call to the same number, and that entry has a name, 
that name is offered as the default.

Whatever the source of the default, you may edit it for corrections or to add notations for the current call 
by typing in the Name to Place in Call Log field.

See Also
Dialing a Call; Redialing a Call from another Application; Storing Frequently Dialed Numbers in Speed-dial
Buttons



Purging Old Calls from the Call Log

To remove entries from the Call Log
1 To empty the Call Log completely, delete the file CALLLOG.TXT from the Windows directory while 

Dialer is not open. Dialer creates a new, empty CALLLOG.TXT file if it finds the file missing when it 
starts up.

2 To remove only some of the entries in the Call Log, open the Call Log window (using Show Log from 
the Options Menu). Select the entry to be deleted, and then select Delete from the Call Log Edit 
menu. You can use the Delete key as a shortcut, or Alt-E, D. Note that deleting a Call Log entry is 
not undo-able.

3 To delete multiple Call Log entries, select the range to be deleted by selecting the first entry in the 
range, and then shift-clicking the last entry in the range. Then use the Delete function as described 
above.

See Also
Viewing the Call Log; Hiding the Call Log; Selecting Types of Calls to Be Entered into the Call Log; 
Placing the Name of the Person Called in the Call Log; Using Call Log Entries in other Applications



Using Call Log Entries in other Applications

The Call Log file, CALLLOG.TXT, is kept in your Windows directory. The entries in the file are separated 
by ASCII CR and LF characters (as in any standard text file). The fields in each entry are separated by 
ASCII TAB characters. In many applications, this format is known as "Tab Delimited." The fields are as 
follows:

· "To:" is displayed if the call as an outgoing call or "From:" if it was an incoming call

· Name

· Number

· Date, in the format specified in the International Control Panel.

· Time the call started, in the format specified in the International Control Panel.

· The duration of the call in minutes, followed by the letters "min."

This file can be easily read and its data can be used by many applications. For example, Microsoft Excel 
can open such tab-delimited text files directly.

See Also
Viewing the Call Log; Hiding the Call Log; Selecting Types of Calls to Be Entered into the Call Log; 
Placing the Name of the Person Called in the Call Log; Purging Old Calls from the Call Log



Setting Dialing Options

To select the line and address on which to dial
1 Select Dialing... from the Options Menu.

2 Select the line you want to dial calls on from the Preferred Line drop-down list. The names in this 
list are obtained from the Telephony service providers that control the telephony hardware devices 
on your system. In general, you can set these names to anything you want to make it easier to know 
which device is which. This you can do using Driver Setup in the Telephony Control Panel.

3 Select the address on which to dial calls from the Preferred Address drop-down list. Most lines 
support only a single address, but if your telephone has multiple phone numbers you may be able to 
choose one on which to dial outgoing calls.

4 Select the location from which you are dialing, from among the locations you have specified in the 
Telephony Control Panel.

5 Select the calling card you wish to use for dialing subsequent calls. Note that your selection of 
location and calling card is relevant only when dialing numbers in international format.

6 Click OK to save your selections, or Cancel to discard your changes.

See Also
Defining Dialing Locations; Defining Telephone Calling Cards; Storing Telephone Numbers to Work from 
any Location



Defining Dialing Locations

To define a dialing location
1 Select Location Setup... from the Options Menu. This opens the list of locations from the Telephony 

Control Panel.

2 Click Add... to define a new location, or select the location you want to change and click Edit....
3 Enter the relevant information for the location, including the location name, access codes for local 

and long distance calls (for example, "9" for an outside line), and area code or city code from which 
calls are dialed (this may be left blank if the country from which calls are placed does not use city 
codes). Select the country from which calls are placed from the drop-down list of country codes.

4 Click OK to save your changes, or Cancel to discard them.

5 Click Close to return to the main Dialer window.

See Also
Dialing a Call; Setting Dialing Options; Defining Telephone Calling Cards; Storing Telephone Numbers to 
Work from any Location



Defining Telephone Calling Cards

To define a calling card
1 Select Calling Card Setup... from the Options Menu. This opens the list of calling cards from the 

Telephony Control Panel.

2 Click Add... to define a new calling card, or select the calling card you want to change and click 
Edit....

3 Enter the name of the card in the Name field, and the card number (if relevant) in the Card Number 
field. 

4 If you are defining a new card rather than simply assigning a number to a predefined card entry, click
Customize... and enter the dialing procedures for using the card. Refer to the Online Help 
information you can obtain from that dialog to learn how to compose these dialing rules. Note that 
you can also copy the rules from other existing calling cards by clicking Copy From... button on the 
Customize... dialog.

4 Click OK to save your changes, or Cancel to discard them.

5 Click Close to return to the main Dialer window.

See Also
Dialing a Call; Setting Dialing Options; Defining Dialing Locations; Storing Telephone Numbers to Work 
from any Location



Storing Telephone Numbers to Work from any Location

Windows Telephony can analyze phone numbers, and, using the information you have supplied for your 
locations and calling cards (in addition to other information Windows Telephony knows about dialing 
procedures in specific countries), determine the proper digits to dial. But for Telephony to accomplish this,
you must provide phone numbers in a particular format known as the international format. This format is 
defined in an international standard (ITU-TS E.123).

The international format is:

+cc (ac) number

where cc is the country code, ac is the area (city) code, and number is the local phone number. If ac is 
specified, it must be preceded by exactly one space and a left parenthesis, and followed by a right 
parenthesis and exactly one space. Only the digits 0 through 9 should appear in cc and ac. number can 
contain dashes, periods, spaces, and other formatting characters.

Numbers you provide that are not in this format will generally be dialed "as is," without the application of 
location or calling card information. One exception to this is if you are in any of the countries in the North 
America Numbering Plan (country code 1), in which the number of digits is fixed (seven-digit local 
numbers, three-digit area codes). If your current location specifies country code 1, Dialer attempts to 
convert the numbers you enter that are not in the international format into the international format by 
adding any missing information (such as the "+", the parentheses, and country code or area code from 
your current location). It does this so that Windows Telephony can then analyze the number and apply the
appropriate dialing procedures based on your selected calling card.

If you are designing an application that is meant to pass dialing requests to Dialer, it is best to obtain the 
phone number information from the user in three separate fields (country code, area code, and local 
number) to make the conversion of the number into international format easier before passing it to Dialer.

See Also
Dialing a Call; Redialing a Call from another Application; Setting Dialing Options; Defining Dialing 
Locations; Defining Telephone Calling Cards



File Menu Commands

The following command is available on the File menu:

Exit Close the Dialer application. You may also close Dialer by selecting Close from 
the System Menu or by double-clicking the System Menu box in the upper-left 
corner of the main Dialer window.



Edit Menu Commands

The following commands are available on the Edit menu:

Cut Cuts the selected text in the Number to Dial field to the clipboard. You may want 
to do this in order to paste the number into a speed-dial button setting. 

Copy Copies the selected text in the Number to Dial field to the clipboard. You may 
want to do this in order to paste the number into a speed-dial button setting. 

Paste Pastes the contents of the clipboard into the Number to Dial field at the insertion
point, or replacing any selection. If the clipboard contains an entry from the Call 
Log, only the Number portion of the entry is pasted into the Number to Dial field.

Delete Deletes the selected text from the Number to Dial field. 

Speed Dial... Opens the Edit Speed Dial dialog, which allows you to make changes to any or 
all the speed-dial buttons at one time. This makes it easier to cut and paste 
between buttons, in case you want to rearrange them or create similar entries.

Note that the shortcut keys for the Edit operations (Ctrl-X, Ctrl-C, Ctrl-V, and Delete) are also available 
when you are editing fields in dialogs such as Edit Speed Dial and Program Speed Dial, even though the 
Edit menu itself is not available.

See Also
How to edit the telephone number before dialing; Storing Frequently Dialed Numbers in Speed-dial 
Buttons; Editing Speed-dial Button Settings



Options Menu Commands

The following commands are available on the Options menu:

Dialing... Opens the Dialing Options dialog so that you can set the line and address on 
which you can to dial calls, and select the location and calling card to use. 

Log... Opens the Call Log Options dialog so that you can select whether or not to place 
entries in the Call Log for incoming and outgoing calls. 

Location Setup... Opens the Locations dialog from the Telephony Control Panel to allow you to 
add, remove, and edit locations. 

Calling Card Setup... Opens the Calling Cards dialog from the Telephony Control Panel to allow you 
to add, remove, edit, and customize calling cards. 

Show/Hide Log Opens and closes the Call Log window. 

See Also
Dialing a Call; Viewing the Call Log; Hiding the Call Log; Selecting Types of Calls to Be Entered into the 
Call Log; Setting Dialing Options; Defining Dialing Locations; Defining Telephone Calling Cards



Help Menu Commands

The following commands are available on the Help menu:

Contents Displays this Help information, beginning at the Contents page. 

About Dialer... Displays the version and other information about Dialer. 



Dialing

This dialog box is displayed when you click the Dial button on the main Dialer window (or one of the other
operations which causes a call to be dialed). It displays the number entered, any name Dialer identified 
associated with that number, the location selected, the calling card selected, and the actual digits 
Windows Telephony decided should be dialed based on those selections.

· Click the Cancel button to stop the dialing and return to the main Dialer window.

· Click the Change Options button to stop the dialing and open the Change Options and Redial 
dialog. In the Change Options and Redial dialog, you can adjust the location and calling card 
settings, modify the toll list, or directly modify the digits to be dialed, and then retry the dialing. You 
may decide to do this if, after clicking Dial, you discover that one or more of the settings is incorrect 
and that the call is being dialed improperly.

Click the Contents button above to see a list of other Help topics.



Dialing Paused

This dialog box is displayed when the digits being dialed specified that it was necessary to wait for a 
particular event on the telephone line, but the Telephony Service Provider for the line you selected cannot
automatically listen to the signals on the phone line and continue dialing at the proper time. You must 
listen (most likely, through the speaker on your modem or similar device) and tell Dialer when to proceed 
with dialing the remainder of the telephone number.

· Click OK to continue dialing, after you hear the tone or signal specified in the dialog message.

· Click Cancel to stop dialing and hang up.

Click the Contents button above to see a list of other Help topics.



Active Call

This dialog box is displayed after the called party answers. It displays the number you entered, the digits 
actually dialed, the name associated with the number, and the location and calling card used to decide 
which digits to dial. It also provides a field in which you can enter the name to be stored in the Call Log for
the entry to be created for this call.

· Click Hangup when you are done speaking. When you click Hangup, the name in the Name to 
Place in Call Log field is written to the Call Log along with other pertinent information.

Click the Contents button above to see a list of other Help topics.



Disconnected Call

This dialog box is displayed if the remote party hangs up. It displays the number you entered, the digits 
actually dialed, the name associated with the number, and the location and calling card used to decide 
which digits to dial. It also provides a field in which you can enter the name to be stored in the Call Log for
the entry to be created for this call.

· Click Close when you are done entering the name field. When you click Close, the name in the 
Name to Place in Call Log field is written to the Call Log along with other pertinent information.

Click the Contents button above to see a list of other Help topics.



Change Options and Redial

This dialog box is displayed when you click the Change Options button in the Dialing dialog. Here, you 
can adjust the location and calling card settings, modify the toll list, or directly modify the digits to be 
dialed, and then retry the dialing. You may decide to do this if you discover after clicking Dial that one or 
more of the settings is incorrect and that the call is being dialed improperly.

Use the Current Location Name drop-down list to select a new location. This causes the number you 
dialed to be reanalyzed and a new set of dialable digits to be displayed based on the new location.

Use the Calling Card to Use drop-down list to select a new calling card. This causes the number you 
dialed to be reanalyzed and a new set of dialable digits to be displayed based on the new card's dialing 
procedures.

The Add to/Remove from Toll List button is disabled if the selected location does not support toll lists. If 
the button is enabled and the caption is Add to Toll List, this means that the prefix portion of the number 
you dialed was not found in the toll list of the current location; clicking this button adds the prefix to the list
and causes Dialer to reanalyze the number and display the updated set of digits to dial. If the button is 
enabled and the caption is Remove from Toll List, this means that the prefix is already in the toll list for 
the current location; clicking this button removes the prefix from the list (so that "1" or "1" plus the area 
code is not dialed before the local number); the updated digits to dial are displayed.

You can also edit the Number to Redial field directly if you want to manually change the digits to be 
dialed.

· Click Redial to cause the digits in the Number to Redial field to be dialed.

· Click Cancel to close the window and return to the main Dialer window without dialing.

See Defining Dialing Locations and Defining Telephone Calling Cards for more details.

Click the Contents button above to see a list of other Help topics.



Line In Use

This dialog box is displayed if you click Dial (or invoke another operation which causes a call to be 
dialed), but the selected line is in use. Normally, this would occur because either another application on 
your computer is using the line, or the line is in use by someone else (perhaps on an extension phone) 
and a dial tone could not be detected.

· Click OK to close the dialog, and try again later when the line is available.

Click the Contents button above to see a list of other Help topics.



Call Log Options

This dialog box is displayed when you select Log... from the Options Menu or Options... from the Log 
menu in the Call Log window. It allows you to select the types of calls to be entered into the Call Log.

· Check Incoming Calls if you want incoming calls to be logged. Be sure it is not checked if you do 
not.

· Check Outgoing Calls if you want outgoing calls to be logged. Be sure it is not checked if you do 
not.

· Click OK to save your changes.

· Click Cancel to discard your changes.

See Selecting Types of Calls to Be Entered into the Call Log for more details.

Click the Contents button above to see a list of other Help topics.



Dialing Options

This dialog is opened when you select Dialing... from the Options Menu. It allows you to select the line on
which you want to dial calls, the address on which to dial, and your current location and the calling card to
use for dialing.

· Click OK to save your selections.

· Click Cancel to discard any changes and return to the main Dialer window.

See Setting Dialing Options for further details.

Click the Contents button above to see a list of other Help topics.



Edit Speed Dial

This dialog box is opened when you select Speed Dial... from the Edit menu. It allows you to make 
changes to any or all of your speed-dial buttons at one time, which is particularly useful for copying the 
contents of one button into another for making similar entries.

If you make a change to one button and then click another speed-dial button, the changes made to the 
previous button are remembered, but do not become permanent until you click Save.

· Click Save to save all your changes.

· Click Cancel to discard all your changes.

See Editing Speed-dial Button Settings for more details.

Click the Contents button above to see a list of other Help topics.



Program Speed Dial

This dialog box is opened when you click an empty speed-dial button, or when you right-click any speed-
dial button. It allows you to change the Name and Number to Dial associated with that button.

· In the Name field, type the text that is to appear on the selected speed-dial button.

· In the Number to Dial field, enter or paste the number you want to dial when you click the button.

· Click Save to store the information on the button.

· Click Save and Dial to both save the information and dial it immediately.

· Click Cancel to discard the changes.

See Storing Frequently Dialed Numbers in Speed-dial Buttons for more details.

Click the Contents button above to see a list of other Help topics.



Call Log

This window is displayed when you select Show Log from the Options Menu. It displays, and allows you 
to perform operations upon, the Call Log.

· Use the Cut command on the Edit menu to delete selected entries from the log and place them on 
the clipboard.

· Use the Copy command on the Edit menu to copy selected entries from the log to the clipboard.

· Use the Delete command on the Edit menu to delete selected entries from the log.

· Use Dial from the Log menu (or press Enter with a log entry selected, or double-click a log entry) to 
redial a call using the number in the log entry.

· Use Options... from the Log menu to display the Call Log Options dialog to select whether incoming
or outgoing calls are logged.

For more details, see Redialing a Call from the Call Log, Viewing the Call Log, Hiding the Call Log, 
Selecting Types of Calls to Be Entered into the Call Log, Placing the Name of the Person Called in the 
Call Log, Purging Old Calls from the Call Log, and Using Call Log Entries in other Applications.

Click the Contents button above to see a list of other Help topics.



About Dialer

This dialog box displays the Dialer version and other pertinent information.

· Click OK to return to the main Dialer window.

Click the Contents button above to see a list of other Help topics.



Dialable
Contains exactly the digits you want to dial. This is often used when calling internal extensions, or special 
numbers such as for reaching an operator, emergency services, or directory assistance.



International
A special format for numbers that allows Windows Telephony to apply the Location and Calling Card 
settings from the Telephony Control Panel and automatically determine the proper digits to dial for you. 
This format is:

+cc (ac) number

where cc is the country code, ac is the area (city) code, and number is the local phone number. If ac is 
specified, it must be preceded by exactly one space and a left parenthesis, and followed by a right 
parenthesis and exactly one space. Only the digits 0 through 9 should appear in cc and ac. number can 
contain dashes, periods, spaces, and other formatting characters.



Call Log
A text file (CALLLOG.TXT) that holds a record of incoming and outgoing calls, including the name of the 
party called (if entered), the number dialed, the date and time the call started, and the duration of the call. 
The file can be displayed in a separate window in Dialer. It is maintained in tab-delimited form so that it 
can be easily imported into other applications.



Line
A device that Windows Telephony applications may use for placing and receiving calls. Generally, it refers
to one connection between your desktop and your telephone company or PBX.



Address
A phone number, usually the number that people would dial to call you on the selected line.



Location
Refers to a set of information Windows Telephony uses when analyzing phone numbers you enter for 
dialing to determine whether they are local, long distance, or international, and then to dial the correct 
digits to place the call. Location information includes your country code, area or city code, and, if you are 
on a PBX, the access code you must dial before local and long-distance numbers (for example, "9"). This 
information is entered and edited in the Telephony Control Panel. You can specify any name you wish for 
the name of the location.



Calling Card
A set of rules, or dialing procedures, for the way to dial a particular call. Each calling card defines a card 
number and the procedures for using that card for local, long distance, and international calls. A calling 
card need not necessarily define rules for an actual telephone credit card; you may also define rules when
you need to directly dial calls using unconventional procedures (for example, when an account code must
be entered after the number called when you are placing a long distance call).



Toll List
In most area codes in North America, from a given location you may dial some numbers using just the 
seven-digit local number, and other locations within the same area code must be dialed using either a "1" 
or "1" plus the area code before the seven-digit number. The calls that require more than just the seven 
digits are known as "toll calls." Generally, you can tell which calls are local and which are toll calls by 
examining the first three digits of the local number (known as the "prefix").

Windows Telephony maintains, for each of the locations in North America, a list of prefixes that must be 
dialed, from that location, as toll calls. This list, known as the "Toll List," can be edited through the 
Telephony Control Panel. Also, applications such as Dialer can allow you to add and remove prefixes from
the toll list directly.






